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Overview

The Telnet application provides virtual terminal services for a wide variety of remote systems, using the 
Telnet Protocol.    Terminal emulations supported include ANSI, VT52, VT100, VT220, and TVI 950 and 
955.    With regard to support for international character sets, note that the PC keyboard displayed in the 
Keyboard Remap window is based on the keyboard setting specified in the International Dialog of the 
Windows Control Panel.

Connection to a specific port (other than the standard port) is provided for additional devices with terminal
login capabilities (such as network routing hubs).    You may have multiple instances of the Telnet 
application active simultaneously.    A Telnet server function is not provided with Chameleon

Note:    An animated icon of a telephone is used to indicate that a connection is established when the 
Telnet application is minimized.    The telephone appears off-hook when connected and on-hook when 
disconnected.

The current preferences and host name can be saved to a configuration file (default is TELNET.CFG).    
The configuration file is loaded when the Telnet application is started.    If a host name is specified, the 
Telnet application automatically connects to the remote system.    A command line argument may also be 
supplied to specify which host or IP address to connect.    An optional second parameter can also be used
to specify the port; otherwise, the standard Telnet port (23) is used.    This host name or IP address is 
displayed in the caption of the Telnet window and appears when the icon is minimized.



Connecting to a Host

To connect to a host system, choose the Connect option from the menu bar.    From the Host Name field, 
type or select the host name to which you want to connect.    The Port field is optional and is set to the 
default (23) Telnet communications port.

From the Emulator field, select the terminal you want to emulate. Select a connection profile, which you 
previously defined using the Connection Profile option, from the List field.    Information such as host 
name, port, emulator parameters, and optional parameters will appear. Choose the OK button to connect.

For detailed information about creating connection profiles, see the Connection Profile description.

Once the connection is established, the window displays a full screen (24 lines by 80 columns) for the 
current font and size selection.

The Edit menu provides Copy, Paste, Line Select, Block Select, Clear Buffer and Reset functions.    You 
can use these functions to extract text to use    in other applications.    All text pasted to the emulation 
window is transmitted directly to the host system.

The Settings menu provides preferences, fonts, and colors options,    logging ability, keyboard mapping, 
button pad configuration, reset size and the connection profile option.

You can use command line parameters to invoke Telnet.    To do this type:

Telnet.exe [<host>] [<port>] ] [options]

where the options are:

-c <connection profile 
name>

use connection 
profile 
description

-f <config> use 
configuration file

-k <keyboard> use keyboard 
file

For example,

TELNET.EXE SUNNY 23 -F    C:\NETMANAG\SUNNY.CFG    -C TEST1

invokes Telnet, connects to the host Sunny on port 23, specifies the configuration file for this Telnet 
session, and invokes the connection profile named Test1.



Setting Up Telnet

The Settings menu allows you to do the following:

        specify preferences, fonts and colors
        activate the Log option and Status Bar
        configure and activate the Button Pad
        use the Reset Size and Keyboard option
        set up the Connection Profile.

Preferences
The Preferences... dialog box allows you to set cursor type, specify carriage returns and linefeeds, set the
page size, history, National Character set, scroll mode and other miscellaneous settings.

You must specify a number of lines for History if you want to have the ability to scroll back to the previous 
page.

You can specify Page size to have more rows than the terminal page that is currently accessible from the 
host.    In this case, the display includes lines from the History.

Mapping Your Keyboard
You can remap and view your keyboard by selecting the Keyboard... option from the Settings menu. A 
display of a PC extended keyboard and a DEC VT100/VT200 keyboard appears.    With regard to support 
for international character sets, note that the PC keyboard displayed in the Keyboard Remap window is 
based on the keyboard setting specified in the International Dialog of the Windows Control Panel.

There are three methods of mapping keys: 

        dragging a key from the DEC keyboard and dropping it on a key located on the PC keyboard

        mapping a string of various escape sequences to a specific key on the PC keyboard

        mapping a Script file to a specific key on the PC keyboard

Dragging and Dropping Pre-mapped Keys
The keyboard mapping allows you to map keys by simply dragging the key you want to map from the 
DEC keyboard and dropping (overlaying) it on top of the desired key on the PC keyboard.

For example, if you want the BS (backspace) key on the PC keyboard to perform a backspace delete 
function, do the following:

1.      Using the mouse, select the Delete key on the DEC keyboard.

2.      Drag the Delete key and place it directly on top of the BS key.    The name of the BS key is replaced 
by the Delete key name.

3.      Save the new mapping as a specific file to use with another Telnet session.

To unmap a PC key, drag the key to the trash icon on the right of the keyboard.    The first time you drag it,
the key will be set to its default value.    The second time you drag it, it will not be set to any key (blank).

Mapping Escape Sequences
You can map a string of various escape sequences to a specific key.    You can use pre-defined key 
sequences or a string based on Octal or Hexadecimal values. 

For example, if you want the backspace key to perform a backspace delete function you can either select 



a pre-defined key or enter your own string.    To use a pre-defined key sequence:

1.      From the Keyboard Mapping screen, select the Macro key.

2.      Drag the Macro key and place it directly on top of the BS key on the PC keyboard.    The String 
Macro Definition dialog box appears.

3.      Delete the entry that appears in the String field.    In this case <BACKSPACE>.

4.      Scroll to DELETE under the Function Key field and choose the Select button.    The word DELETE 
now appears in the Script field.

5.      Choose the OK button.    The name of the BS key is replaced by the Delete key name.

To define your own key sequence using Octal or Hexadecimal characters:

1.      From the Keyboard Mapping screen, select the Macro key.

2.      Drag the Macro key and place it directly on top of the BS key on the PC keyboard.    The String 
Macro Definition dialog box appears.

3.      Delete the entry that appears in the String field.    In this case <BACKSPACE>.

4.      Enter the value \177 (the Octal value for delete).    Choose the OK button.    The BS key is renamed 
to MAC for macro and now performs the delete function.

Note:    Please refer to the Keyboard... entry under Telnet Online Help for detailed information about using
Octal and Hexadecimal values.

Mapping a Script File
You can map a Script file to a specific key on your PC keyboard.    To do this:

1.      From the Keyboard Mapping screen, select the Script key.

2.      Drag the Script key and place it directly on top of the key you want to map on the PC keyboard.    The
Choose a Script File dialog box appears.

3.      Select the desired drive, directory, and script file you want to map and choose the OK button.

4.      The key you mapped is renamed to SCR for the selected Script file.

Mapping the CTRL, SHIFT and ALT Keys

The CTRL, ALT, SHIFT, CTRL SHIFT, and ALT SHIFT keys are available for keyboard mapping.    To map 
these keys, do the following:

1.      From Keyboard Mapping screen, select the desired key combination on the PC keyboard, for 
example, the CTRL SHIFT keys.    Both these keys will be highlighted in yellow, and the remaining 
keys will appear unlabled.

2.      Select and drag a key from the DEC keyboard and place it directly on top of the key you want to map
on PC keyboard.

To view the entire mapped PC keyboard, select PC layout from the View menu.    You can save the 
mapped keyboard to a file by selecting the Save option from the File menu.



Configuring the Button Pad

The Button Pad Configuration...option allows you to configure the button pad located at the bottom of the 
Telnet screen.    You can use pre-defined string or your own script.    By configuring this button pad,    you 
can have easy access to commonly used keys.    When enabled, the Button Pad option (located under the
Settings menu) displays a button pad at the bottom of the Telnet window.    

Using a Pre-Defined String

To configure the Button Pad using a pre-defined string, do the following:

1.      Select the Button Pad Configuration... option from the Settings menu.    The Button Pad 
Configuration dialog box appears.

2.      Scroll through the String field and select the pre-defined string you want the button pad to perform.    
For example, choose <DELETE> if you want to perform a backspace delete function.

3.      Type in the name of the key you want to appear on your button pad.    For example, enter bkdel (for 
backspace delete) to appear on the configured button pad.

4.      Choose the Add button, and then the OK button to save the new button pad configuration.

Using a Script
To configure the Button Pad using a script, do the following:

1.      Select the Button Pad Configuration... option from the Settings menu.    The Button Pad 
Configuration dialog box appears.

2.      Choose the Build... button to display the String Macro Definition dialog box.

3.      Choose the Script... button to display the Choose a script file dialog box.    Select the desired drive, 
directory, and script file name, then choose the OK button.

4.      The selected script file name appears in the String field of the String Macro Definition dialog box.    
Choose the OK button to return to the Button Pad Configuration dialog box.

5.      Enter the name you want to appear on the button pad in the Name field.    For example, enter the 
name demo to appear on the button pad.

6.      Choose the Add button, and then the OK button to save the configuration.

Button Pad Configuration Option Fields
The Button Pad Configuration option fields are:

Field Field Entry
String: Actual key that is sent to the host when the button 

is pressed.
Description List: Identifies the assigned key and its function.    
Build...button Displays the String Macro Definition dialog box.    

Mapped Key:  The name of the key assigned to the
button pad.
Function Key:    Pre-defined key or keys that 
appear in the String field and conveys the actual 
function of the key you are configuring.
String:    Pre-defined key sequence or enter a script
(using the Script... button).    This is the actual key 
sequence sent to the host when the button pad key 
is pressed.
Script... button:    Displays the Choose a Script 



File dialog box where you can select a script.
Size... button Displays the Button Pad Size dialog box.  Max 

Button in Row:    Indicates number of buttons in 
the button pad.    You can define up to 20 buttons.    
The button pad adjusts automatically to the 
assigned number.
Button Width:    Indicates the number of characters
used to label a button.    10 characters is maximum.



Defining Connection Profiles

Connection profiles can be created for both standard use and for Itelnet security purposes.

Standard Connection Profiles

The Connection Profile... option allows you to set and store a list of frequently used connections.    You 
can define a host, port, machine you want to emulate, login prompt, username, password prompt, 
password, and a description field for each profile.    These connection profiles, whose description names 
will appear on the Connect menu, allow you to connect automatically to a host.

To create a connection profile:

1.      Select Connection Profile... option from the Settings menu.

2.      Enter the name of the specific connection profile in the Description field.    This identifying name will 
then appear on the Connect menu in the Description List field.

3.      Enter all field information and choose the OK button.

The Connection Profile fields are:

Field Field Entry
Host Name: Name or IP address of the host to which you are 

connecting.
Port: The default (23) Telnet communications port.
Emulated Terminal: Name of the terminal you want to emulate.
Reply As: Some Telnet hosts require that the terminal identify 

itself differently than the standard Telnet name ( for 
example, DEC-VT1 instead of the usual VT100).    If 
your host needs such identification.

Login Prompt: The actual login prompt.    For example, LOGIN.
Username: The username that you use to login.
Pwd Prompt: The actual password prompt.    For example, 

PASSWORD.
Password: The password you want entered at the Pwd Prompt. 

This will be invisible to the user.
Browse... button Displays the Open a script file dialog box.    Allows 

you to browse and select the desired script.
Script: Contains selected Script file.
Description List: Lists all Connection Profiles by their name in the 

Description field.

Itelnet Security Connection Profile

Itelnet is a security mechanism provided by Sun for the Sun/OS platform.    It allows users to telnet 
through a security gateway to other corporate internal or out to the Internet.    When using Telnet for this 
purpose you need to fill out your Connection Profile fields as follows:

Field Field Entry
Description: Itelnet
Host Name: Name or IP address of the host to which you are 

connecting.
Port: The port number must be 4514
Emulated Terminal: Name of the terminal you want to emulate.
Reply As: Some Telnet hosts require that the terminal 

identify itself differently than the standard Telnet 
name ( for example, DEC-VT1 instead of the 
usual VT100).    If your host needs such 
identification.

Login Prompt: The actual login prompt.    For example, LOGIN:
Username: The username that you use to login.





Using Scripts

The Script menu allows you to    edit and execute scripts by accessing the Visual Script Editor and Visual 
Script Player directly through Telnet.    You can create a new script, modify an existing script, or execute a 
script 



New

New creates a new configuration template.    When you choose the New option, Telnet provides you with a
default configuration template (file).

To select a new configuration:

Select the New option from the File menu.



Open...

Open... opens an existing configuration file.    When you select Open, Telnet allows you to load an existing
configuration file.

To open a new configuration file:

1.      Select the Open... option from the File menu.

2.      Select the desired Drive, directory and file.

3.      Choose the OK button.



Save

Save saves configuration parameter changes to the default file.

To save configuration parameter changes:

Select the Save option from the File menu.



Save As...

Save As... allows you to select the file name, directory, and drive you want to use for saving configuration 
parameters.

To save configuration parameters in desired location:

1.      Select the Save As... option from the File menu.

2.      Select the desired drive and directory.

3.      Enter the filename into the text box.

4.      Choose the OK button.



Capture to file...

Capture to file... allows you to capture all the data on the current screen and send it to a text file.

To capture the current screen data and send it to a text file:

1.      Select the Capture to file... option from the File menu.

2.      Select the desired drive and directory.

3.      Enter the filename into the text box.

4.      Choose the OK button.



Print...

Print... allows you to print the contents of the emulated screen to your windows printer, or to save the data
in a file.

To print the full page of the screen plus the history (requires that a number of lines has already been 
specified for history):

1.      Select the Print... option from the File menu.

2.      Choose the All option from Print Range, and choose the OK button.

To print portions of the screen:

1.      Select the text area that you want to print.

2.      Select the Print... option from the File menu.

3.      Select the Choose option from Print Range, and choose the OK button.

To print the full page of the screen currently accessible from the host:

1.      Select the Print... option from the File menu.

2.      Choose the Terminal Page option from Print Range, and choose the OK button.



Print Setup...

Print Setup... allows you to modify the printer configuration.

To modify the printer setup:

1.      Select the Print Setup... option from the File menu.

2.      Select either the default printer or a specific printer.

3.      Select additional options according to the specific printer.

Note: If you select the option "Use host control codes," Telnet expects the printer control codes to be 
sent from the host.    If the host does not send printer control codes and this option is selected, the printing
function will not work.

4.      Choose the OK button.'



Printer Auto Mode

Printer Auto Mode directs all screen data from the host to the printer.



Printer Control Mode

Printer Control Mode directs all data from the host to the printer instead of sending data to the screen.



Exit

Exit allows you to exit Telnet.

To exit Telnet:

Select the Exit option from the File menu.



Copy

Copy allows you to copy selected text from the Telnet window into the Clipboard, leaving the original 
intact and erasing the previous Clipboard contents.

To copy text:

1.      Select the text using your mouse.

2.      Select the Copy option from the Edit menu.



Paste

Paste allows you to add text from the Clipboard into the Telnet window.

To paste Clipboard text:

1.      Place the cursor where you want the clipboard text to be inserted.

2.    Select the Paste option from the Edit menu.



Line Select

Line Select allows you to select one or more full lines of data on the current screen ( instead of block 
select which selects a rectangular block of text).

To select one or more lines of data:

1.      Select the Line Select option from the Edit menu.

2.      Highlight the desired text on the current screen.



Block Select

Block Select allows you to select a rectangular block of data on the current screen (instead of line select 
which selects full lines of text).

To select a block of text:

1.      Select the Select option from the Edit menu.

2.      Highlight the desired text on the current screen.



Clear Buffer

Clear Buffer allows you to reset information in the terminal buffer to the initial state of all Blank.

To clear the buffer:

Select the Clear Buffer option from the Edit menu.



Reset Terminal

Reset terminal sets the Telnet session back to pre-session parameters and clears the screen of data 
without disconnecting the session.



Connect

Connect allows you to connect between this computer and a host on the network.    You can establish a 
connection by entering the target host name, port number, and the machine you want to emulate.    

You can also establish a connection automatically by selecting a pre-defined connection that is listed in 
the Description List field.    You can create pre-defined connections using the Connection Profile... option 
under the Settings menu.

To establish a connection:

1.      Choose the Connect menu.

2.      Enter the host name (target host), port number if appropriate (default is Telnet port 23), and the 
machine you want to emulate in the appropriate fields.    Or, to connect automatically, select a pre-
defined name from the list in the Description List field.

3.      Choose the OK button.



Disconnect

Disconnect allows you to close the connection between this computer and a host on the network, or to 
exit out of Telnet.

To disconnect or exit Telnet:

1.      Select the Disconnect menu.

2.      To disconnect, select the Disconnect button.

3.      To exit Telnet, select the Exit button.



Preferences

Terminal Modes allows you to select the Local Echo mode or Sound mode.

Local Echo:    Displays your keystrokes on your terminal.    If the remote computer echoes your 
keystrokes, leave Local Echo off.

Sound:    Turns on the system bell for the remote computer.

CR -> CR/LF

Specifying Carriage Returns and Linefeeds (CR to CR/LF)

To cause a carriage return to be interpreted as a carriage return plus a linefeed:

1.      Select the Inbound and/or Outbound check boxes in the Terminal Preferences dialog box.

2.      Choose the OK button.

Note:    Select the Inbound or Outbound options according to how the remote computer handles the end 
of a line and what it expects from other computers.    If the remote computer sends carriage returns only, 
select Inbound.    If the remote computer sends carriage returns followed by linefeeds, do not select 
Inbound.    If the remote computer expects to receive carriage returns and add its own linefeeds, do not 
select Outbound.

Cursor

Specifying the Cursor

To specify how the cursor appear:

1.      Select the Block or Vertical line option buttons to specify the cursor's shape.

2.      Select the Dim check box to dim the cursor.

Columns

Specifying Number of Columns for Your Emulated Terminal

To specify columns:

Select the 80 or 132 option button in the Terminal Preferences dialog box.

Note:  To set an 80-column monitor to terminal as a wide terminal specify 132.    The terminal reserves 
132 columns for text whether 132 columns are entered or received.    When you use a large value you 
may scroll the back horizontally to see previous data that was sent to your terminal.    If desired, you can 
select this data for copy or print.

History
Setting the Buffer Lines

To set how many lines of information are saved in the buffer for scroll back:

1.      Select the Preferences... option from the Settings menu.



2.      Enter a number between 25 and 999 in the History text box.    If you enter a number higher than 
available memory permits, Terminal sets the buffer lines to the largest number permitted.

Note:    If the emulation is in block mode the scroll back area may be irrelevant.

National Character Set

National Character Set (NRC) is a method that partially solves multinational character problem in 7 bit 
mode.    It replaces some of the ASCII characters to the specified language's characters.    The NRC 
supports 12 languages including USACII.

To select the NRC:

Select the NRC option.    Your keyboard input will be filtered before it is transmitted to the remote hose.

Note:    In this mode, characters such as #, @, [,\,].. cannot be used.

Enable Alt+Keypad Input

To select extended ASCII characters:

Select the Enable Alt+Keypad Input option.

To use extended ASCII characters, type the desired keypad numbers while holding the Alt key down.

Smooth/Jump Scrolling

Smooth/Jump Scrolling allows you to scroll either line by line (smooth) or window by window (jump).

To select the smooth or jump scrolling:

1.      Select the Preferences... option from the Settings menu.

2.      Select either the Smooth or Jump box under the Scrolling option.

3.      Choose the OK button.



Fonts...

Fonts... allows you to select the desired font, font type and size for your screen display.

To select a font:

1.      Select the Fonts... option from the Settings menu.

2.      Select the desired font, font type and font size.

3.      Choose the OK button.



Colors...

Colors... allows you to select both the foreground and background colors for your screen display.    A 
palette of 16 colors is available.

The Items field displays the options: Normal, Blink, Bold, Reverse, Blink Bold, Blink Reverse, Blink Bold 
Reverse, and Bold Reverse.    Item is the type of data specified by your host.    Usually the normal color is 
used, but when the host indicates that a certain area on the screen should be bold or blinking, then that 
area is displayed in the specific color assigned to the that item.

To select colors for your screen display:

1.      Select the Colors... option from the Settings menu.

2.      Select the background color and the foreground color.

3.      Select the item.

4.      Choose the OK button.

Note:  To set a particular color back to the default, choose the Default button.    To set all colors back to 
the factory set default colors, choose the    All Defaults button.    When reverse video is set by the host, 
then the background and foreground colors are switched.



Log...

The Log... option allows you to diagnose client and host transmission problems.    You can use Log for 
debugging purposes by saving data that is transferred between the terminal emulation program and 
Telnet host into a file.

To log data:

1.      Select the Log... option from the Settings menu.

2.      Select the Log to Disk checkbox to start the Log.    A dialog box appears where you enter the name of
the file that will contain the log information.    To turn the Log... option off, deselect the Log to Disk 
checkbox.

3.      Select the Play Log checkbox to play back log information for debugging purposes when you are not 
connected to a real host.

Note:    If you send a log file that indicates a problem, start the Log before connecting to your host.    The 
log file is always called PLNET.LOG.    It is located in the directory that is used to start Telnet.



Status Bar

Status Bar allows you to display or hide the application's status bar.    The status bar is displayed a the 
bottom of the window where it shows messages and provides statistics about the current application.



Button Pad

Button Pad enables or disables the button pad.    The customized button pad appears at the bottom of the 
Telnet screen and allows easy access to keypad buttons you most often use.

Select the Button Pad option to enable the button pad, or deselect the Button Pad option to disable the 
button pad.



Keyboard...

You can remap and view your keyboard by selecting the Keyboard... option from the Settings menu. A 
display of a PC extended keyboard and a DEC VT100/VT200 keyboard appears.

There are three methods of mapping keys: 

        dragging a key from the DEC keyboard and dropping it on a key located on the PC keyboard

        mapping a string of various escape sequences to a specific key on the PC keyboard

        mapping a Script file to a specific key on the PC keyboard

Dragging and Dropping Pre-mapped Keys

The keyboard mapping allows you to map keys by simply dragging the key you want to map from the 
DEC keyboard and dropping (overlaying) on top of the desired key on the PC keyboard.

For example, if you want the BS (backspace) key on the PC keyboard to perform a backspace delete 
function, do the following:

1.      Using the mouse, select the Delete key on the DEC keyboard.

2.      Drag the Delete key and place it directly on top of the BS key.    The name of the BS key is replaced 
by the Delete key name.

3.      Save the new mapping as a specific file to use with another Telnet session.

To unmap a PC key, drag the key to the trash icon on the right of the keyboard.    The first time you drag it,
the key will be set to its default value.    The second time you drag it, it will not be set to any key (blank).

Mapping Escape Sequences

You can map a string of various escape sequences to a specific key.    You can use pre-defined key 
sequences or a string based on Octal or Hexadecimal values.    

For example, if you want the backspace key to perform a backspace delete function you can either select 
a pre-defined key or enter your own string.    To use a pre-defined key sequence:

1.      From the Keyboard Mapping screen, select the Macro key.

2.      Drag the Macro key and place it directly on top of the BS key on the PC keyboard.    The String 
Macro Definition dialog box appears.

3.      Delete the entry that appears in the String field.    In this case <BACKSPACE>.

4.      Scroll to DELETE under the Function Key field and choose the Select button.    The word DELETE 
now appears in the Script field.

5.      Choose the OK button.    The name of the BS key is replaced by the Delete key name.

To define your own key sequence using Octal or Hexadecimal characters:

1.      From the Keyboard Mapping screen, select the Macro key.

2.      Drag the Macro key and place it directly on top of the BS key on the PC keyboard.    The String 



Macro Definition dialog box appears.

3.      Delete the entry that appears in the String field.    In this case <BACKSPACE>.

4.      Enter the value \177 (the Octal value for delete).    Choose the OK button.    The BS key is renamed 
to MAC for macro and now performs the delete function.

Conventions when using Octal and Hexadecimal values:

\E - Escape character.

^X - Control character, a carriage return can be represented ^M.    An escape character can be 
represented as ^[.

\OOO - Octal equivalent of the character.    As an example character 'A' can be represented as \101.    A 
carriage return character, ^M, can be represented as \015. The "Delete" key (used by 
many systems for "Backspace") is \177.

Following you will find ASCII table:

      Octal - Character

|000 NUL|001 SOH|002 STX|003 ETX|004 EOT|005 ENQ|006 ACK|007 BEL|
|010 BS |011 HT |012 NL |013 VT |014 NP |015 CR |016 SO |017 SI |
|020 DLE|021 DC1|022 DC2|023 DC3|024 DC4|025 NAK|026 SYN|027 ETB|
|030 CAN|031 EM |032 SUB|033 ESC|034 FS |035 GS |036 RS |037 US |
|040 SP |041  ! |042  " |043  # |044  $ |045  % |046  & |047  ' |
|050  ( |051  ) |052  * |053  + |054  , |055  - |056  . |057  / |
|060  0 |061  1 |062  2 |063  3 |064  4 |065  5 |066  6 |067  7 |
|070  8 |071  9 |072  : |073  ; |074  < |075  = |076  > |077  ? |
|100  @ |101  A |102  B |103  C |104  D |105  E |106  F |107  G |
|110  H |111  I |112  J |113  K |114  L |115  M |116  N |117  O |
|120  P |121  Q |122  R |123  S |124  T |125  U |126  V |127  W |
|130  X |131  Y |132  Z |133  [ |134  \ |135  ] |136  ^ |137  _ |
|140  ` |141  a |142  b |143  c |144  d |145  e |146  f |147  g |
|150  h |151  i |152  j |153  k |154  l |155  m |156  n |157  o |
|160  p |161  q |162  r |163  s |164  t |165  u |166  v |167  w |
|170  x |171  y |172  z |173  { |174  | |175  } |176  ~ |177 DEL|

      Hexadecimal - Character

| 00 NUL| 01 SOH| 02 STX| 03 ETX| 04 EOT| 05 ENQ| 06 ACK| 07 BEL|
| 08 BS | 09 HT | 0A NL | 0B VT | 0C NP | 0D CR | 0E SO | 0F SI |
| 10 DLE| 11 DC1| 12 DC2| 13 DC3| 14 DC4| 15 NAK| 16 SYN| 17 ETB|
| 18 CAN| 19 EM | 1A SUB| 1B ESC| 1C FS | 1D GS | 1E RS | 1F US |
| 20 SP | 21  ! | 22  " | 23  # | 24  $ | 25  % | 26  & | 27  ' |
| 28  ( | 29  ) | 2A  * | 2B  + | 2C  , | 2D  - | 2E  . | 2F  / |
| 30  0 | 31  1 | 32  2 | 33  3 | 34  4 | 35  5 | 36  6 | 37  7 |
| 38  8 | 39  9 | 3A  : | 3B  ; | 3C  < | 3D  = | 3E  > | 3F  ? |
| 40  @ | 41  A | 42  B | 43  C | 44  D | 45  E | 46  F | 47  G |
| 48  H | 49  I | 4A  J | 4B  K | 4C  L | 4D  M | 4E  N | 4F  O |
| 50  P | 51  Q | 52  R | 53  S | 54  T | 55  U | 56  V | 57  W |
| 58  X | 59  Y | 5A  Z | 5B  [ | 5C  \ | 5D  ] | 5E  ^ | 5F  _ |
| 60  ` | 61  a | 62  b | 63  c | 64  d | 65  e | 66  f | 67  g |
| 68  h | 69  i | 6A  j | 6B  k | 6C  l | 6D  m | 6E  n | 6F  o |
| 70  p | 71  q | 72  r | 73  s | 74  t | 75  u | 76  v | 77  w |



| 78  x | 79  y | 7A  z | 7B  { | 7C  | | 7D  } | 7E  ~ | 7F DEL|

      Decimal - Character

|  0 NUL|  1 SOH|  2 STX|  3 ETX|  4 EOT|  5 ENQ|  6 ACK|  7 BEL|
|  8 BS |  9 HT | 10 NL | 11 VT | 12 NP | 13 CR | 14 SO | 15 SI |
| 16 DLE| 17 DC1| 18 DC2| 19 DC3| 20 DC4| 21 NAK| 22 SYN| 23 ETB|
| 24 CAN| 25 EM | 26 SUB| 27 ESC| 28 FS | 29 GS | 30 RS | 31 US |
| 32 SP | 33  ! | 34  " | 35  # | 36  $ | 37  % | 38  & | 39  ' |
| 40  ( | 41  ) | 42  * | 43  + | 44  , | 45  - | 46  . | 47  / |
| 48  0 | 49  1 | 50  2 | 51  3 | 52  4 | 53  5 | 54  6 | 55  7 |
| 56  8 | 57  9 | 58  : | 59  ; | 60  < | 61  = | 62  > | 63  ? |
| 64  @ | 65  A | 66  B | 67  C | 68  D | 69  E | 70  F | 71  G |
| 72  H | 73  I | 74  J | 75  K | 76  L | 77  M | 78  N | 79  O |
| 80  P | 81  Q | 82  R | 83  S | 84  T | 85  U | 86  V | 87  W |
| 88  X | 89  Y | 90  Z | 91  [ | 92  \ | 93  ] | 94  ^ | 95  _ |
| 96  ` | 97  a | 98  b | 99  c |100  d |101  e |102  f |103  g |
|104  h |105  i |106  j |107  k |108  l |109  m |110  n |111  o |
|112  p |113  q |114  r |115  s |116  t |117  u |118  v |119  w |
|120  x |121  y |122  z |123  { |124  | |125  } |126  ~ |127 DEL|

Mapping a Script File

You can map a Script file to a specific key on your PC keyboard.    To do this:

1.      From the Keyboard Mapping screen, select the Script key.

2.      Drag the Script key and place it directly on top of the key you want to map on the PC keyboard.    The
Choose a Script File dialog box appears.

3.      Select the desired drive, directory, and script file you want to map and choose the OK button.

4.      The key you mapped is renamed to SCR for the selected Script file.

Mapping the CTRL, SHIFT and ALT Keys

The CTRL, ALT, SHIFT, CTRL SHIFT, and ALT SHIFT keys are available for keyboard mapping.    To map 
these keys, do the following:

1.      From Keyboard Mapping screen, select the desired key combination on the PC keyboard, for 
example, the CTRL SHIFT keys.    Both these keys will be highlighted in yellow, and the remaining 
keys will appear unlabled.

2.      Select and drag a key from the DEC keyboard and place it directly on top of the key you want to map
on PC keyboard.

To view the entire mapped PC keyboard, select PC layout from the View menu.    You can save the 
mapped keyboard to a file by selecting the Save option from the File menu.



Button Pad Configuration...

The Button Pad Configuration...option allows you to configure the button pad located at the bottom of the 
Telnet screen.    You can use pre-defined string or your own script.    By configuring this button pad,    you 
can have easy access to commonly used keys.    When enabled, the Button Pad option (located under the
Settings menu) displays a button pad at the bottom of the Telnet window.    

Using a Pre-Defined String

To configure the Button Pad using a pre-defined string, do the following:

1.      Select the Button Pad Configuration... option from the Settings menu.    The Button Pad 
Configuration dialog box appears.

2.      Scroll through the String field and select the pre-defined string you want the button pad to perform.    
For example, choose <DELETE> if you want to perform a backspace delete function.

3.      Type in the name of the key you want to appear on your button pad.    For example, enter bkdel (for 
backspace delete) to appear on the configured button pad.

4.      Choose the Add button, and then the OK button to save the new button pad configuration.

Using a Script

To configure the Button Pad using a script, do the following:

1.      Select the Button Pad Configuration... option from the Settings menu.    The Button Pad 
Configuration dialog box appears.

2.      Choose the Build... button to display the String Macro Definition dialog box.

3.      Choose the Script... button to display the Choose a script file dialog box.    Select the desired drive, 
directory, and script file name, then choose the OK button.

4.      The selected script file name appears in the String field of the String Macro Definition dialog box.    
Choose the OK button to return to the Button Pad Configuration dialog box.

5.      Enter the name you want to appear on the button pad in the Name field.    For example, enter the 
name demo to appear on the button pad.

6.      Choose the Add button, and then the OK button to save the configuration.

Button Pad Configuration Option Fields

The Button Pad Configuration option fields are:

Name: Identifies a key that you want to assign to the button 
pad.    This is the name of the key that appears on the 
button pad on the bottom of the Telnet screen when the
Button Pad option is enabled.

String: Actual key that is sent to the host when the button is 
pressed.

Description List: Identifies the assigned key and its function.    
Build...button Displays the String Macro Definition dialog box.    

Mapped Key:  The name of the key assigned to the 
button pad.
Function Key:    Pre-defined key or keys that appear in
the String field and conveys the actual function of the 



key you are configuring.
String:    Pre-defined key sequence or enter a script 
(using the Script... button).    This is the actual key 
sequence sent to the host when the button pad key is 
pressed.
Script... button:    Displays the Choose a Script File 
dialog box where you can select a script.

Size... button Displays the Button Pad Size dialog box.  Max Button 
in Row:    Indicates number of buttons in the button 
pad.    You can define up to 20 buttons.    The button 
pad adjusts automatically to the assigned number.
Button Width:    Indicates the number of characters 
used to label a button.    10 characters is maximum.



Reset Size

Reset Size allows you to reset the Telnet window to the original default size.    Upon startup, Telnet sizes 
the window to 24 lines by 80 characters based on the selected/default font size.    

To reset the window size:

Select the Reset size option from the Settings menu.



Connection Profile...

The Connection Profile... option allows you to set and store a list of frequently used connections.    The 
Description names of the connection profiles will appear on the Connect menu, allowing you to connect 
automatically to a host.    A connection profile generally includes the host, port, and desired terminal 
emulation.    A profile may also include the login prompt, username, password prompt, and password.    
For additional custom options, a script file may also be specified.

To create a connection profile:

1.      Select Connection Profile... option from the Settings menu.

2.      Enter the name of the specific connection profile in the Description field.    This identifying name will 
then appear on the Connect menu in the Description List field. You must specify a Description.

3.      Enter other field information, as desired, and choose the OK button.

The Connection Profile fields are:

Description: Name of the connection that appears on the List field
in the Connect option dialog box.

Host Name: Name or IP address of the host to which you are 
connecting.

Port: The default (23) Telnet communications port.
Emulated Terminal: Name of the terminal you want to emulate.
Reply As: Some Telnet hosts require that the terminal identify 

itself differently than the standard Telnet name ( for 
example, DEC-VT1 instead of the usual VT100).    If 
your host needs such identification.

Login Prompt: The actual login prompt.    For example, USER
Username: The username to be automatically entered at the 

login prompt.
Pwd Prompt: The actual password prompt.    For example, 

PASSWORD
Password: The password to be automatically entered at the 

Pwd Prompt.    The password will be invisible to the 
user..

Browse... button Displays the Open a script file dialog box.    Allows 
you to browse through a list of existing script 
filenames and select the desired script.

Script: Contains the name of the selected Script file.
Description List: Lists all Connection Profiles by their name in the 

Description field.



New...

New... allows you to create a script.    

To create a script:

1.      Select the New... option, and you see an initial template appear on your screen.    Enter your script 
commands in this template. 

2.      Use the various menu items in the EditScr dialog box (File, Edit, Assist, Run, Settings, Window, 
Help) to help you create and execute the script.

Note:    For more explanation about the menu items under the Script menu (File, Edit, Assist, etc.), refer to
the Visual Script Editor and Visual Script Player chapter in this manual.



Modify...

Modify... allows you to modify an existing script.

To modify a script:

1.      Select the Modify... option from the Script menu.

2.      Select the file, directory, and drive in the Choose Script File dialog box.    Choose the OK button, and 
the selected file appears on the screen, ready to be modified.    If you need help when you are editing 
your file, see the Visual Script Editor and Visual Script Player chapter for more details.



Execute...

Execute... allows you to execute your script.    

To execute your script:

1.      Select the Execute option from the Script menu.

2.      Select the file, directory, and drive in the Choose Script File dialog box. Choose the OK button, and 
your script is executed.



Are You There?...

Are You There?... allows you to send an ARE YOU THERE? Telnet command to the connected host.    If 
the host is connected, the host will reply and this reply will be displayed.    The reply differs from one host 
to another, however UNIX hosts usually reply with the test "Yes."



Send Break

Send Break allows you to send a Telnet IAC break to the host.



Pause

Pause allows you to stop all screen activity without breaking the connection.



Diagnose Connection

Use the Diagnose Connection option to start Ping and verify that the server is available.



Contents

Using Help

To choose a Help topic:

Mouse
Point to the underlined topic you want to view and click the mouse button.

When the pointer is over an item you can choose, the pointer changes to a hand icon.

Keyboard
Press Tab to move the highlight to the underlined topic you want to view, and then press Enter.

To exit Help:

Mouse                        1      Point to the File menu and click the mouse button.

2      Click the Exit command.

Keyboard                    1      Press Alt.
2      Type the letter F.
3      Type the letter X.



Troubleshooting

If you experience difficulties using the Telnet application, refer to the following items:

o Verify that the installation and setup verification steps have been successfully completed.

o Make sure that the remote system provides a Telnet server; note that Chameleon does not provide a 
Telnet server.

o Ensure that the Connect port is correct; it should be the default (23) in almost all cases.

o Use the Ping application to verify connectivity to any remote system to which you want access if Telnet 
reports a failure to connect.

o Verify that emulation was specified correctly when you connected if the window display appears 
incorrect.

o Disconnect and change the History setting in the Preferences dialog box to scroll further back.

o Select Reset Size from the Settings menu if full-screen applications appear to not fit correctly within the 
Telnet window.

o Check to see that the appropriate font and size is installed if graphic characters appear incorrectly.

o Check to see that the appropriate font and size is installed, or scroll horizontally if 132-column mode 
does not fit within the Telnet window.



About Telnet...

Select the About Telnet... option under the Help menu for more information about the program.    Choose 
the OK button to continue.






